$re = '`(?:\bgoogle\.com$)|(?:\bgoogle\.com\.au$)|(\bgoogle\..*)`m';
$str = 'Should not match:
google.com.au
google.com
Should match:
google.net
google.org
google.com.pk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);