using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<((?!<).)*(:\n)((?!<).)*>)*(((?!<).)*)(<\/(((?!<).)*)>)*";
string input = @" <p class=3DMsoNormal style=3D'mso-layout-grid-align:none'><span style=3D'font-size:
8.0pt'>$</span><span lang=3DEN-US style=3D'font-size:8.0pt;mso-ansi-language:
EN-US'>ogrnNomer</span><span style=3D'font-size:8.0pt'>$</span><span
style=3D'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:
RU'><o:p></o:p></span></p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}