import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<((?!<).)*(:\\n)((?!<).)*>)*(((?!<).)*)(<\\/(((?!<).)*)>)*";
final String string = " <p class=3DMsoNormal style=3D'mso-layout-grid-align:none'><span style=3D'font-size:\n"
+ "8.0pt'>$</span><span lang=3DEN-US style=3D'font-size:8.0pt;mso-ansi-language:\n"
+ " EN-US'>ogrnNomer</span><span style=3D'font-size:8.0pt'>$</span><span\n"
+ " style=3D'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:\n"
+ " RU'><o:p></o:p></span></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}