const regex = /(<((?!<).)*(:\n)((?!<).)*>)*(((?!<).)*)(<\/(((?!<).)*)>)*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<((?!<).)*(:\\n)((?!<).)*>)*(((?!<).)*)(<\\\/(((?!<).)*)>)*', 'mg')
const str = ` <p class=3DMsoNormal style=3D'mso-layout-grid-align:none'><span style=3D'font-size:
8.0pt'>\$</span><span lang=3DEN-US style=3D'font-size:8.0pt;mso-ansi-language:
EN-US'>ogrnNomer</span><span style=3D'font-size:8.0pt'>\$</span><span
style=3D'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:
RU'><o:p></o:p></span></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}