re = /(<((?!<).)*(:\n)((?!<).)*>)*(((?!<).)*)(<\/(((?!<).)*)>)*/m
str = ' <p class=3DMsoNormal style=3D\'mso-layout-grid-align:none\'><span style=3D\'font-size:
8.0pt\'>$</span><span lang=3DEN-US style=3D\'font-size:8.0pt;mso-ansi-language:
EN-US\'>ogrnNomer</span><span style=3D\'font-size:8.0pt\'>$</span><span
style=3D\'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:
RU\'><o:p></o:p></span></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end