import re
regex = re.compile(r"(<((?!<).)*(:\n)((?!<).)*>)*(((?!<).)*)(<\/(((?!<).)*)>)*", flags=re.MULTILINE)
test_str = (" <p class=3DMsoNormal style=3D'mso-layout-grid-align:none'><span style=3D'font-size:\n"
"8.0pt'>$</span><span lang=3DEN-US style=3D'font-size:8.0pt;mso-ansi-language:\n"
" EN-US'>ogrnNomer</span><span style=3D'font-size:8.0pt'>$</span><span\n"
" style=3D'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:\n"
" RU'><o:p></o:p></span></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")