use strict;
my $str = ' <p class=3DMsoNormal style=3D\'mso-layout-grid-align:none\'><span style=3D\'font-size:
8.0pt\'>$</span><span lang=3DEN-US style=3D\'font-size:8.0pt;mso-ansi-language:
EN-US\'>ogrnNomer</span><span style=3D\'font-size:8.0pt\'>$</span><span
style=3D\'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:
RU\'><o:p></o:p></span></p>';
my $regex = qr/(<((?!<).)*(:\n)((?!<).)*>)*(((?!<).)*)(<\/(((?!<).)*)>)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}