using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[>])\s+(?=[<])";
string substitution = @"";
string input = @"<!DOCTYPE html>
<html>
<body>
<h1>My Test Heading</h1>
<a href>text1 text2</a>
<% testfunction() %>
<p>My Test paragraph.</p>
</body>
</html>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}