import Foundation
let pattern = #"(?<=[>])\s+(?=[<])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!DOCTYPE html>
<html>
<body>
<h1>My Test Heading</h1>
<a href>text1 text2</a>
<% testfunction() %>
<p>My Test paragraph.</p>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)