const regex = /(?<=[>])\s+(?=[<])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[>])\\s+(?=[<])', 'g')
const str = `<!DOCTYPE html>
<html>
<body>
<h1>My Test Heading</h1>
<a href>text1 text2</a>
<% testfunction() %>
<p>My Test paragraph.</p>
</body>
</html>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);