$re = '/(?<=[>])\s+(?=[<])/';
$str = '<!DOCTYPE html>
<html>
<body>
<h1>My Test Heading</h1>
<a href>text1 text2</a>
<% testfunction() %>
<p>My Test paragraph.</p>
</body>
</html>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;