#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)"
Local $sString = "https://www.example.com/product/download" & @CRLF & _
"https://www.example.com/product/download/" & @CRLF & _
"https://www.example.com/product/download?cmp" & @CRLF & _
"" & @CRLF & _
"http://www.example.com/product/download" & @CRLF & _
"http://www.example.com/product/download/" & @CRLF & _
"http://www.example.com/product/download?cmp" & @CRLF & _
"" & @CRLF & _
"https://example.com/product/download" & @CRLF & _
"https://example.com/product/download/" & @CRLF & _
"https://example.com/product/download?cmp" & @CRLF & _
"" & @CRLF & _
"http://example.com/product/download" & @CRLF & _
"http://example.com/product/download/" & @CRLF & _
"http://example.com/product/download?cmp" & @CRLF & _
"" & @CRLF & _
"<a href="/product-category/product-name/download">Download Tool</a>" & @CRLF & _
"<a href="https://www.example.com/product-category/product-name/download">Download Tool</a>" & @CRLF & _
"<a href="http://www.example.com/product-category/product-name/download">Download Tool</a>" & @CRLF & _
"<a href="www.example.com/product-category/product-name/download">Download Tool</a>" & @CRLF & _
"<a href="example.com/product-category/product-name/download">Download Tool</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")