using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)";
string input = @"https://www.example.com/product/download
https://www.example.com/product/download/
https://www.example.com/product/download?cmp
http://www.example.com/product/download
http://www.example.com/product/download/
http://www.example.com/product/download?cmp
https://example.com/product/download
https://example.com/product/download/
https://example.com/product/download?cmp
http://example.com/product/download
http://example.com/product/download/
http://example.com/product/download?cmp
<a href=""/product-category/product-name/download"">Download Tool</a>
<a href=""https://www.example.com/product-category/product-name/download"">Download Tool</a>
<a href=""http://www.example.com/product-category/product-name/download"">Download Tool</a>
<a href=""www.example.com/product-category/product-name/download"">Download Tool</a>
<a href=""example.com/product-category/product-name/download"">Download Tool</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}