$re = '/(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)/m';
$str = 'https://www.example.com/product/download
https://www.example.com/product/download/
https://www.example.com/product/download?cmp
http://www.example.com/product/download
http://www.example.com/product/download/
http://www.example.com/product/download?cmp
https://example.com/product/download
https://example.com/product/download/
https://example.com/product/download?cmp
http://example.com/product/download
http://example.com/product/download/
http://example.com/product/download?cmp
<a href="/product-category/product-name/download">Download Tool</a>
<a href="https://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="http://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="www.example.com/product-category/product-name/download">Download Tool</a>
<a href="example.com/product-category/product-name/download">Download Tool</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);