// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)").unwrap();
let string = "https://www.example.com/product/download
https://www.example.com/product/download/
https://www.example.com/product/download?cmp
http://www.example.com/product/download
http://www.example.com/product/download/
http://www.example.com/product/download?cmp
https://example.com/product/download
https://example.com/product/download/
https://example.com/product/download?cmp
http://example.com/product/download
http://example.com/product/download/
http://example.com/product/download?cmp
<a href=\"/product-category/product-name/download\">Download Tool</a>
<a href=\"https://www.example.com/product-category/product-name/download\">Download Tool</a>
<a href=\"http://www.example.com/product-category/product-name/download\">Download Tool</a>
<a href=\"www.example.com/product-category/product-name/download\">Download Tool</a>
<a href=\"example.com/product-category/product-name/download\">Download Tool</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}