const regex = /(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(h?t?t?p?s?:?\\\/?\\\/?w?w?w?.example.com\\\/.*\\\/[Dd]ownload.*\\??)', 'gm')
const str = `https://www.example.com/product/download
https://www.example.com/product/download/
https://www.example.com/product/download?cmp
http://www.example.com/product/download
http://www.example.com/product/download/
http://www.example.com/product/download?cmp
https://example.com/product/download
https://example.com/product/download/
https://example.com/product/download?cmp
http://example.com/product/download
http://example.com/product/download/
http://example.com/product/download?cmp
<a href="/product-category/product-name/download">Download Tool</a>
<a href="https://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="http://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="www.example.com/product-category/product-name/download">Download Tool</a>
<a href="example.com/product-category/product-name/download">Download Tool</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}