use strict;
my $str = 'https://www.example.com/product/download
https://www.example.com/product/download/
https://www.example.com/product/download?cmp
http://www.example.com/product/download
http://www.example.com/product/download/
http://www.example.com/product/download?cmp
https://example.com/product/download
https://example.com/product/download/
https://example.com/product/download?cmp
http://example.com/product/download
http://example.com/product/download/
http://example.com/product/download?cmp
<a href="/product-category/product-name/download">Download Tool</a>
<a href="https://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="http://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="www.example.com/product-category/product-name/download">Download Tool</a>
<a href="example.com/product-category/product-name/download">Download Tool</a>';
my $regex = qr/(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}