import Foundation
let pattern = #"(h?t?t?p?s?:?\/?\/?w?w?w?.example.com\/.*\/[Dd]ownload.*\??)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.example.com/product/download
https://www.example.com/product/download/
https://www.example.com/product/download?cmp
http://www.example.com/product/download
http://www.example.com/product/download/
http://www.example.com/product/download?cmp
https://example.com/product/download
https://example.com/product/download/
https://example.com/product/download?cmp
http://example.com/product/download
http://example.com/product/download/
http://example.com/product/download?cmp
<a href="/product-category/product-name/download">Download Tool</a>
<a href="https://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="http://www.example.com/product-category/product-name/download">Download Tool</a>
<a href="www.example.com/product-category/product-name/download">Download Tool</a>
<a href="example.com/product-category/product-name/download">Download Tool</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)