#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^\QThis patch requires:\E\R*" & @CRLF & _
"\K" & @CRLF & _
"(?:^Patch.+\R)+"
Local $sString = "This patch requires:" & @CRLF & _
"" & @CRLF & _
"Patch 1.10-1" & @CRLF & _
"Patch 1.11-2" & @CRLF & _
"" & @CRLF & _
"Notes:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")