import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\QThis patch requires:\\E\\R*\n"
+ "\\K\n"
+ "(?:^Patch.+\\R)+";
final String string = "This patch requires:\n\n"
+ "Patch 1.10-1\n"
+ "Patch 1.11-2\n\n"
+ "Notes:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}