import re
regex = re.compile(r"""
^\QThis patch requires:\E\R*
\K
(?:^Patch.+\R)+
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("This patch requires:\n\n"
"Patch 1.10-1\n"
"Patch 1.11-2\n\n"
"Notes:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")