const regex = new RegExp('^\\QThis patch requires:\\E\\R*
\\K
(?:^Patch.+\\R)+', 'gm')
const str = `This patch requires:
Patch 1.10-1
Patch 1.11-2
Notes:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}