// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^\QThis patch requires:\E\R*
\K
(?:^Patch.+\R)+").unwrap();
let string = "This patch requires:
Patch 1.10-1
Patch 1.11-2
Notes:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}