$re = '~^\QThis patch requires:\E\R*
\K
(?:^Patch.+\R)+~mx';
$str = 'This patch requires:
Patch 1.10-1
Patch 1.11-2
Notes:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);