const regex = /(?<=\S)\s*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\S)\\s*$', 'gmi')
const str = `Line 1
Line 2
Line 3
Line 4
Line 5`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);