import Foundation
let pattern = #"(?<=\S)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Line 1
Line 2
Line 3
Line 4
Line 5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)