re = /(?<=\S)\s*$/mi
str = 'Line 1
Line 2
Line 3
Line 4
Line 5'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result