use strict;
my $str = 'Line 1
Line 2
Line 3
Line 4
Line 5';
my $regex = qr/(?<=\S)\s*$/mip;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";