#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#(\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#"
Local $sString = "{" & @CRLF & _
" //Remove this comment" & @CRLF & _
" "Command": "storeSystemConfig"," & @CRLF & _
" "SystemId": "1234", //Remove this comment" & @CRLF & _
"" & @CRLF & _
" /*Remove this and the empty line above and below*/" & @CRLF & _
"" & @CRLF & _
"/*Remove this comment but not what behind here =>*/ "TestParam": "Hello"," & @CRLF & _
" "TestString": "Do not revome this comment /*don not remove*/ and also this one: //Test comment"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")