$re = '/#(\\\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#/';
$str = '{
//Remove this comment
"Command": "storeSystemConfig",
"SystemId": "1234", //Remove this comment
/*Remove this and the empty line above and below*/
/*Remove this comment but not what behind here =>*/ "TestParam": "Hello",
"TestString": "Do not revome this comment /*don not remove*/ and also this one: //Test comment"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);