// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#(\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#").unwrap();
let string = "{
//Remove this comment
\"Command\": \"storeSystemConfig\",
\"SystemId\": \"1234\", //Remove this comment
/*Remove this and the empty line above and below*/
/*Remove this comment but not what behind here =>*/ \"TestParam\": \"Hello\",
\"TestString\": \"Do not revome this comment /*don not remove*/ and also this one: //Test comment\"
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}