import Foundation
let pattern = ##"#(\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
//Remove this comment
"Command": "storeSystemConfig",
"SystemId": "1234", //Remove this comment
/*Remove this and the empty line above and below*/
/*Remove this comment but not what behind here =>*/ "TestParam": "Hello",
"TestString": "Do not revome this comment /*don not remove*/ and also this one: //Test comment"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)