package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#(\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#`)
var str = `{
//Remove this comment
"Command": "storeSystemConfig",
"SystemId": "1234", //Remove this comment
/*Remove this and the empty line above and below*/
/*Remove this comment but not what behind here =>*/ "TestParam": "Hello",
"TestString": "Do not revome this comment /*don not remove*/ and also this one: //Test comment"
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}