import re
regex = re.compile(r"#(\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#")
test_str = ("{\n"
" //Remove this comment\n"
" \"Command\": \"storeSystemConfig\",\n"
" \"SystemId\": \"1234\", //Remove this comment\n\n"
" /*Remove this and the empty line above and below*/\n\n"
"/*Remove this comment but not what behind here =>*/ \"TestParam\": \"Hello\",\n"
" \"TestString\": \"Do not revome this comment /*don not remove*/ and also this one: //Test comment\"\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")