using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(\\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|([\s\t]\/.*)|(^\/.*)#";
string input = @"{
//Remove this comment
""Command"": ""storeSystemConfig"",
""SystemId"": ""1234"", //Remove this comment
/*Remove this and the empty line above and below*/
/*Remove this comment but not what behind here =>*/ ""TestParam"": ""Hello"",
""TestString"": ""Do not revome this comment /*don not remove*/ and also this one: //Test comment""
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}