#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!127|10|192\.168)(?:\d{1,3}\.){3}\d{1,3}(?:/\d{1,2})?"
Local $sString = "10.0.0.0" & @CRLF & _
"11.0.0.0" & @CRLF & _
"126.0.0.0" & @CRLF & _
"127.0.0.0" & @CRLF & _
"127.123.0.0" & @CRLF & _
"128.123.0.0" & @CRLF & _
"192.168.0.0" & @CRLF & _
"192.169.0.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")