use strict;
my $str = '10.0.0.0
11.0.0.0
126.0.0.0
127.0.0.0
127.123.0.0
128.123.0.0
192.168.0.0
192.169.0.0';
my $regex = qr~\b(?!127|10|192\.168)(?:\d{1,3}\.){3}\d{1,3}(?:/\d{1,2})?~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}