$re = '~\b(?!127|10|192\.168)(?:\d{1,3}\.){3}\d{1,3}(?:/\d{1,2})?~m';
$str = '10.0.0.0
11.0.0.0
126.0.0.0
127.0.0.0
127.123.0.0
128.123.0.0
192.168.0.0
192.169.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);