const regex = new RegExp('\\b(?!127|10|192\\.168)(?:\\d{1,3}\\.){3}\\d{1,3}(?:/\\d{1,2})?', 'gm')
const str = `10.0.0.0
11.0.0.0
126.0.0.0
127.0.0.0
127.123.0.0
128.123.0.0
192.168.0.0
192.169.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}