# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?!127|10|192\.168)(?:\d{1,3}\.){3}\d{1,3}(?:/\d{1,2})?"
test_str = ("10.0.0.0\n"
"11.0.0.0\n"
"126.0.0.0\n"
"127.0.0.0\n"
"127.123.0.0\n"
"128.123.0.0\n"
"192.168.0.0\n"
"192.169.0.0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.