using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!127|10|192\.168)(?:\d{1,3}\.){3}\d{1,3}(?:/\d{1,2})?";
string input = @"10.0.0.0
11.0.0.0
126.0.0.0
127.0.0.0
127.123.0.0
128.123.0.0
192.168.0.0
192.169.0.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}