# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)/----\n$1\n/g;t' <<< "
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
a
stuff here
more stuff here
maybe even more here"