import Foundation
let pattern = #"(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
a
stuff here
more stuff here
maybe even more here
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"----\n$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)