#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)"
Local $sString = "" & @CRLF & _
"stuff here" & @CRLF & _
"more stuff here" & @CRLF & _
"maybe even more here" & @CRLF & _
"" & @CRLF & _
"stuff here" & @CRLF & _
"more stuff here" & @CRLF & _
"maybe even more here" & @CRLF & _
"" & @CRLF & _
"stuff here" & @CRLF & _
"more stuff here" & @CRLF & _
"maybe even more here" & @CRLF & _
"a" & @CRLF & _
"stuff here" & @CRLF & _
"more stuff here" & @CRLF & _
"maybe even more here"
Local $sSubst = "----\n$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)