$re = '/(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)/';
$str = '
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
a
stuff here
more stuff here
maybe even more here';
$subst = "----\n$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;