use strict;
my $str = '
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
a
stuff here
more stuff here
maybe even more here';
my $regex = qr/(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)/p;
my $subst = '----\\n$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";