const regex = /(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\r?\\n|^)((?:\\r?\\n|.)+?)(?=\\r?\\n\\r?\\n|$)', 'g')
const str = `
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
a
stuff here
more stuff here
maybe even more here`;
const subst = `----\n$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);