re = /(?:\r?\n|^)((?:\r?\n|.)+?)(?=\r?\n\r?\n|$)/
str = '
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
stuff here
more stuff here
maybe even more here
a
stuff here
more stuff here
maybe even more here'
subst = '----\\n$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result