import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+.)+ (\\w)";
final String string = "1.43.7.112. Teste.\n"
+ "26.0.177. Teste.\n"
+ "1.1.1.1.1. Teste. Teste1.\n"
+ "1.1.1.1. Teste\n"
+ "1. Teste\n"
+ "1.43.7.112. Teste. 1.43.7.112. Teste.\n"
+ "1.43.7.112. \n"
+ "1.43.7.112. 123teste\n"
+ "1.43.7.112. _este.";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}