# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+.)+ (\w)"
test_str = ("1.43.7.112. Teste.\n"
"26.0.177. Teste.\n"
"1.1.1.1.1. Teste. Teste1.\n"
"1.1.1.1. Teste\n"
"1. Teste\n"
"1.43.7.112. Teste. 1.43.7.112. Teste.\n"
"1.43.7.112. \n"
"1.43.7.112. 123teste\n"
"1.43.7.112. _este.")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.